user ${srv} ${owner}
'';
};
+ sanoid.datasets."rpool/var/lib/${srv}" = {
+ use_template = [ "snap" ];
+ daily = 31;
+ monthly = 3;
+ recursive = true;
+ };
};
systemd.services = {
nginx = {
+sbwtdcpu none
+sbwtdio none
'';
+ unitConfig = {
+ StartLimitBurst = 5;
+ StartLimitIntervalSec = "600s";
+ };
serviceConfig = {
LoadCredentialEncrypted = [ "config.exs:${./pleroma/config.exs.cred}" ];
SupplementaryGroups = [ groups."postgres".name ];
TimeoutStopSec = "10s";
+ Restart = "on-failure";
+ RestartSec = "10s";
# For sendmail
NoNewPrivileges = lib.mkForce false;
};