losurdo: allow access to Yubikey USB node
[sourcephile-nix.git] / shell / gnupg.nix
index d4ec3c0b579973c01ff6d933987dc1aa0f869aab..d4f774ce80bce53001a2b1b3937ac5600f235515 100644 (file)
@@ -29,12 +29,12 @@ gnupg.keys = {
 };
 } // lib.listToAttrs (
   let domain = "sourcephile.fr"; in
-  builtins.map (machine: lib.nameValuePair "root@${machine}.${domain}" {
-  uid = "root@${machine}.${domain}";
+  builtins.map (host: lib.nameValuePair "root@${host}.${domain}" {
+  uid = "root@${host}.${domain}";
   algo = "rsa4096";
   expire = "0";
   usage = ["cert" "sign"];
-  passPath = "machines/${machine}/root/key.pass";
+  passPath = "hosts/${host}/root/key.pass";
   subKeys = [
     { algo = "rsa4096"; expire = "0"; usage = ["encrypt"]; }
   ];