tor: update PR#97740
[sourcephile-nix.git] / nixos / defaults.nix
index 7d112608be2809ee48e8ba49a87840abf5f9d731..c2317f19fbb4050d6676c1c156a21a599315d47e 100644 (file)
@@ -25,7 +25,7 @@ nix = {
     "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
   ];
 };
-environment.etc."nixpkgs".source = inputs.nixpkgs;
+environment.etc."nixpkgs".source = pkgs.path;
 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
 
 nixpkgs = {
@@ -94,9 +94,9 @@ services = {
   journald = {
     extraConfig = ''
       Compress=true
-      MaxRetentionSec=3month
+      MaxRetentionSec=1month
       Storage=persistent
-      SystemMaxUse=500M
+      SystemMaxUse=128M
     '';
   };
 };
@@ -109,8 +109,8 @@ environment.systemPackages = with pkgs; [
   dstat
   gnupg
   htop
-  inetutils
   iftop
+  inetutils
   iotop
   ldns
   linuxPackages.cpupower
@@ -122,10 +122,13 @@ environment.systemPackages = with pkgs; [
   nload
   nmon
   pv
+  smem
+  stress
   swaplist
   tcpdump
   tmux
   tree
+  usbutils
   vim
   which
 ];
@@ -178,5 +181,6 @@ programs = {
   };
   mosh.enable = true;
   mtr.enable = true;
+  traceroute.enable = true;
 };
 }