mermet: miniflux: enable DynamicUser=
[sourcephile-nix.git] / hosts / carotte.nix
index 96083ef96c19c899bc3ccd888933114172e499fa..9da8195be3ff85c12a701bacc96f629b9d3c768b 100644 (file)
@@ -1,25 +1,34 @@
 # NixOS configuration of carotte.sourcephile.fr
-{ inputs, hostName, ... }:
+{ inputs, hostName, lib, ... }:
 {
-nixpkgs.hostPlatform = {
-  system = "armv7l-linux";
-  config = "armv7l-unknown-linux-gnueabihf";
-};
-imports = [
-  {
-    install.substituteOnDestination = false;
-  }
-  ../nixos/defaults.nix
-  ../nixos/profiles/systems/debug.nix
-  #carotte/fileSystems.nix
+  nixpkgs.buildPlatform = {
+    system = "x86_64-linux";
+    config = "x86_64-unknown-linux-gnu";
+  };
+  nixpkgs.hostPlatform = {
+    system = "armv7l-linux";
+    config = "armv7l-unknown-linux-gnueabihf";
+  };
+  imports = [
+    {
+      install.substituteOnDestination = false;
+    }
+    #(inputs.julm-nix + "/nixos/profiles/builder.nix")
+    "${inputs.julm-nix}/nixos/profiles/lang-fr.nix"
+    "${inputs.julm-nix}/nixos/profiles/networking/remote.nix"
+    "${inputs.julm-nix}/nixos/profiles/dnscrypt-proxy2.nix"
+    #../nixos/profiles/systems/debug.nix
+    #carotte/fileSystems.nix
 
-  carotte/hardware.nix
-  carotte/hostapd.nix
-  carotte/networking.nix
-  carotte/security.nix
-  carotte/system.nix
-  carotte/users.nix
-  (inputs.secrets + "/hosts/${hostName}/users.nix")
-  #carotte/xserver.nix
-];
+    carotte/hardware.nix
+    #carotte/hostapd.nix
+    carotte/nebula.nix
+    carotte/nftables.nix
+    carotte/networking.nix
+    carotte/security.nix
+    carotte/system.nix
+    carotte/users.nix
+    #(inputs.secrets + "/hosts/${hostName}/users.nix")
+    carotte/xserver.nix
+  ];
 }