{ pkgs, lib, config, ... }:
{
-hardware.cpu.amd.updateMicrocode = true;
-nix = {
- # Too CPU hungry for the APU2, for too little Mio saved
- autoOptimiseStore = false;
- maxJobs = 4;
+
+nixpkgs.hostPlatform = {
+ system = "x86_64-linux";
+ config = "x86_64-unknown-linux-gnu";
};
+_module.args.CPUs = 4;
+hardware.cpu.amd.updateMicrocode = true;
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
# https://insanity.industries/post/sata-power-consumption/
];
kernelModules = [
"igb"
+ # Enable boot from SD card
+ "sdhci_pci"
];
};