prosody: increase http_file_share limits
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index cfa6e8f4818daf70a8baeaff24031b9d341a6807..1265548e47659a83e34ba86ff4900f8c4517261a 100644 (file)
@@ -1,11 +1,16 @@
 { pkgs, lib, config, ... }:
 {
-hardware.cpu.amd.updateMicrocode = true;
-nix = {
-  # Too CPU hungry for the APU2, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = 4;
+
+nixpkgs.hostPlatform = {
+  system = "x86_64-linux";
+  config = "x86_64-unknown-linux-gnu";
 };
+_module.args.CPUs = 4;
+hardware.cpu.amd.updateMicrocode = true;
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
 # https://insanity.industries/post/sata-power-consumption/
@@ -58,6 +63,8 @@ boot.initrd = {
   ];
   kernelModules = [
     "igb"
+    # Enable boot from SD card
+    "sdhci_pci"
   ];
 };