networking: fix MTU problems in wireguard
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index cfa6e8f4818daf70a8baeaff24031b9d341a6807..a9e3073d4726c8b1f32c9eb4d837f80baff9ecf7 100644 (file)
@@ -1,10 +1,10 @@
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
 {
 hardware.cpu.amd.updateMicrocode = true;
 nix = {
   # Too CPU hungry for the APU2, for too little Mio saved
   autoOptimiseStore = false;
-  maxJobs = 4;
+  maxJobs = host.CPUs / 2;
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";