-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, hostName, ... }:
let
inherit (config) networking;
inherit (config.services) nginx;
add rule inet filter net2fw tcp dport 80 counter accept comment "HTTP"
add rule inet filter net2fw tcp dport 443 counter accept comment "HTTPS"
'';
+fileSystems."/var/lib/nginx" = {
+ device = "${hostName}/var/www";
+ fsType = "zfs";
+};
services.upnpc.redirections = [
{ description = "HTTP"; externalPort = 80; protocol = "TCP"; duration = 30 * 60;
service.wantedBy = ["nginx.service"];