nix: update inputs
[sourcephile-nix.git] / hosts / losurdo / nginx / sourcephile.fr / cryptpad.nix
index 42f2b39cc7cfcd1949280d886bf00ae88131f2bc..5269365a3c8be7992c148f8fe38b3fbdb1550657 100644 (file)
@@ -73,8 +73,8 @@ services.cryptpad = {
       httpUnsafeOrigin: 'https://${main_domain}/',
       httpSafeOrigin: "https://${sandbox_domain}/",
       httpAddress: '::1',
-      httpPort: 3000,
-      httpSafePort: 3001,
+      httpPort: 3100,
+      httpSafePort: 3101,
       maxWorkers: 1,
 
       /* =====================
@@ -146,7 +146,7 @@ fileSystems."/var/lib/private/cryptpad" = {
 
 services.sanoid.datasets = {
   "${hostName}/var/cryptpad" = {
-    use_template = [ "local" ];
+    use_template = [ "snap" ];
     daily = 31;
   };
 };
@@ -183,7 +183,7 @@ services.nginx.virtualHosts.${main_domain} = {
   # We prefer to serve static content from nginx directly and to leave the API server to handle
   # the dynamic content that only it can manage. This is primarily an optimization
   locations."^~ /cryptpad_websocket" = {
-    proxyPass = "http://[::1]:3000";
+    proxyPass = "http://[::1]:3100";
     proxyWebsockets = true;
   };
 
@@ -202,7 +202,7 @@ services.nginx.virtualHosts.${main_domain} = {
   # the caching variable which is applied to every other resource
   # which is loaded during that session.
   locations."= /api/config" = {
-    proxyPass = "http://[::1]:3000";
+    proxyPass = "http://[::1]:3100";
   };
 
   # encrypted blobs are immutable and are thus cached for a year
@@ -257,7 +257,7 @@ services.nginx.virtualHosts.${main_domain} = {
   '';
 
   extraConfig = ''
-    access_log /var/log/nginx/${domain}/${srv}/access.log json buffer=32k;
+    access_log /var/log/nginx/${domain}/${srv}/access.json json buffer=32k;
     error_log  /var/log/nginx/${domain}/${srv}/error.log warn;
 
     index index.html;