httpUnsafeOrigin: 'https://${main_domain}/',
httpSafeOrigin: "https://${sandbox_domain}/",
httpAddress: '::1',
- httpPort: 3000,
- httpSafePort: 3001,
+ httpPort: 3100,
+ httpSafePort: 3101,
maxWorkers: 1,
/* =====================
services.sanoid.datasets = {
"${hostName}/var/cryptpad" = {
- use_template = [ "local" ];
+ use_template = [ "snap" ];
daily = 31;
};
};
# We prefer to serve static content from nginx directly and to leave the API server to handle
# the dynamic content that only it can manage. This is primarily an optimization
locations."^~ /cryptpad_websocket" = {
- proxyPass = "http://[::1]:3000";
+ proxyPass = "http://[::1]:3100";
proxyWebsockets = true;
};
# the caching variable which is applied to every other resource
# which is loaded during that session.
locations."= /api/config" = {
- proxyPass = "http://[::1]:3000";
+ proxyPass = "http://[::1]:3100";
};
# encrypted blobs are immutable and are thus cached for a year
'';
extraConfig = ''
- access_log /var/log/nginx/${domain}/${srv}/access.log json buffer=32k;
+ access_log /var/log/nginx/${domain}/${srv}/access.json json buffer=32k;
error_log /var/log/nginx/${domain}/${srv}/error.log warn;
index index.html;