-{ pkgs, lib, config, ... }:
+{ inputs, ... }:
{
-imports = [
- ../../nixos/profiles/hardware/apu2e4.nix
- ../../nixos/profiles/systems/zramSwap.nix
-];
+ imports = [
+ ../../nixos/profiles/hardware/apu2e4.nix
+ (inputs.julm-nix + "/nixos/profiles/zramSwap.nix")
+ ];
-# The 32-bit host id of the host, formatted as 8 hexadecimal characters.
-# You should try to make this id unique among your hosts.
-# Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
-networking.hostId = "69c40b03";
+ # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
+ # You should try to make this id unique among your hosts.
+ # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
+ networking.hostId = "69c40b03";
-boot.loader.grub.devices = [
- "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
-];
+ boot.loader.grub.devices = [
+ "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
+ ];
-fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
- fsType = "ext2";
- };
-
-fileSystems."/boot/efi" =
- { device = "/dev/disk/by-uuid/62E6-E65F";
- fsType = "vfat";
- };
+ fileSystems."/boot" =
+ {
+ device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
+ fsType = "ext2";
+ };
-swapDevices = [
- { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
- randomEncryption = {
- enable = true;
- cipher = "aes-xts-plain64";
- source = "/dev/urandom";
+ fileSystems."/boot/efi" =
+ {
+ device = "/dev/disk/by-uuid/62E6-E65F";
+ fsType = "vfat";
};
- }
-];
+
+ swapDevices = [
+ {
+ device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
+ randomEncryption = {
+ enable = true;
+ cipher = "aes-xts-plain64";
+ source = "/dev/urandom";
+ };
+ }
+ ];
}