losurdo: enable SD cards mounting
[sourcephile-nix.git] / hosts / losurdo / hardware.nix
index 751571d9c9db41bcbe8f5af7edf4cec0e0090dc5..bc630ae2bb37cc2d600f73c1a80a83aafa2434d1 100644 (file)
@@ -5,6 +5,8 @@ imports = [
   ../../nixos/profiles/systems/zramSwap.nix
 ];
 
+hardware.opengl.enable = true;
+
 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
 # You should try to make this id unique among your hosts.
 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
@@ -43,4 +45,7 @@ swapDevices = [
     };
   }
 ];
+
+# Allow access to Yubikey USB device nodes.
+services.udev.packages = [ pkgs.yubikey-personalization ];
 }