sourcehut: factorize commonPreStart
[sourcephile-nix.git] / hosts / losurdo / system.nix
index ba1d40c4034f619727818b1dee713dc0c1925f66..9e12dcda33382bbbbfc58d36cae3a75a0010617e 100644 (file)
@@ -1,6 +1,7 @@
 { pkgs, lib, config, ... }:
 let
   inherit (config) networking;
+  inherit (config.security) gnupg;
 in
 {
 # This value determines the NixOS release with which your system is to be
@@ -8,12 +9,15 @@ in
 # You should change this only after NixOS release notes say you should.
 system.stateVersion = "19.09"; # Did you read the comment?
 
+nix.gc.dates = "weekly";
+nix.gc.options = "--delete-older-than 7d";
+
 # Avoid the use of systemd-run --user --scope tmux
 # and let mosh work smoothly.
 services.logind.killUserProcesses = false;
 
-nix.gc.dates = "weekly";
-nix.gc.options = "--delete-older-than 7d";
+hardware.bluetooth.enable = true;
+#services.blueman.enable = true;
 
 documentation.nixos = {
   enable = false; # NOTE: useless on a server, and CPU intensive.
@@ -21,10 +25,11 @@ documentation.nixos = {
 
 boot.kernelParams = [
   # Rotate the consoles anti-clockwise.
-  "fbcon=rotate:3"
+  #"fbcon=rotate:3"
 ];
 
 environment.systemPackages = with pkgs; [
+  bluez
   cryptsetup
   direnv
   f3
@@ -41,7 +46,7 @@ environment.systemPackages = with pkgs; [
   socat
   sanoid
   #iptables-nftables-compat
-  gnupg
+  pkgs.gnupg
   miniupnpc
   audit
   python