{ pkgs, lib, config, ... }:
let
inherit (config) networking;
+ inherit (config.security) gnupg;
in
{
# This value determines the NixOS release with which your system is to be
# You should change this only after NixOS release notes say you should.
system.stateVersion = "19.09"; # Did you read the comment?
+nix.gc.dates = "weekly";
+nix.gc.options = "--delete-older-than 7d";
+
# Avoid the use of systemd-run --user --scope tmux
# and let mosh work smoothly.
services.logind.killUserProcesses = false;
-nix.gc.dates = "weekly";
-nix.gc.options = "--delete-older-than 7d";
+hardware.bluetooth.enable = true;
+#services.blueman.enable = true;
documentation.nixos = {
enable = false; # NOTE: useless on a server, and CPU intensive.
boot.kernelParams = [
# Rotate the consoles anti-clockwise.
- "fbcon=rotate:3"
+ #"fbcon=rotate:3"
];
environment.systemPackages = with pkgs; [
+ bluez
cryptsetup
direnv
f3
socat
sanoid
#iptables-nftables-compat
- gnupg
+ pkgs.gnupg
miniupnpc
audit
python