losurdo: allow oignon's SSH key
[sourcephile-nix.git] / hosts / losurdo / users.nix
index bb1153956a83bc057e0c59c7613a83bdc75b252d..2998249a2548ee21c963f8e47ca9dbc005cf75cd 100644 (file)
@@ -44,9 +44,9 @@ users = {
   };
 };
 
-security.gnupg.secrets."/root/.ssh/id_ed25519" = {
-  gpg = "${gnupg.store}/ssh/root.ssh-ed25519.gpg";
-};
+#security.gnupg.secrets."/root/.ssh/id_ed25519" = {
+#  gpg = "${gnupg.store}/ssh/root.ssh-ed25519.gpg";
+#};
 
 networking.nftables.ruleset = lib.concatMapStringsSep "\n"
   (rule: "add rule inet filter fw2net meta skuid ${users.julm.name} " + rule) [
@@ -54,10 +54,12 @@ networking.nftables.ruleset = lib.concatMapStringsSep "\n"
   ''tcp dport 43 counter accept comment "Whois"''
   ''tcp dport 993 counter accept comment "IMAPS"''
   ''tcp dport 6697 counter accept comment "IRCS"''
+  ''tcp dport 2222 counter accept comment "SSH(boot)"''
   ''tcp dport 5222 counter accept comment "XMPP"''
   ''tcp dport 11371 counter accept comment "HKP"''
   ''tcp dport {9009,9010,9011,9012,9013} counter accept comment "croc"''
   ''udp dport 33434-33523 counter accept comment "traceroute"''
+  ''udp dport 60000-61000 counter accept comment "Mosh"''
   #''ip protocol tcp counter accept comment "all"''
 ];
 }