-{ pkgs, lib, config, ... }:
+{ inputs, pkgs, lib, config, ... }:
let inherit (lib) types;
inherit (config.networking) hostName domain;
in
{
imports = [
./modules.nix
- defaults/security.nix
+ ./options.nix
+ (inputs.julm-nix + "/nixos/profiles/security.nix")
defaults/predictable-interface-names.nix
];
nix = {
#binaryCaches = lib.mkForce [];
extraOptions = ''
'';
- autoOptimiseStore = lib.mkDefault true;
+ settings.auto-optimise-store = lib.mkDefault true;
# Use gc.automatic to keep disk space under control.
gc.automatic = lib.mkDefault true;
gc.dates = lib.mkDefault "weekly";
gc.options = lib.mkDefault "--delete-older-than 30d";
# Setting NIX_PATH is useless now that flake.nix are used.
- nixPath = lib.mkForce [];
+ nixPath = [];
};
environment.variables.NIXPKGS_CONFIG = lib.mkForce "";
documentation.nixos = {
- enable = lib.mkDefault false; # NOTE: useless on a server, and CPU intensive.
+ # NOTE: useless on a server, and CPU intensive.
+ enable = lib.mkDefault false;
};
console.font = "Lat2-Terminus16";
usePredictableInterfaceNames = true;
};
-services.journald = {
- extraConfig = ''
- Compress=true
- MaxRetentionSec=1month
- Storage=persistent
- SystemMaxUse=128M
- '';
-};
+services.logrotate.enable = true;
services.openssh.enable = true;
inetutils
iotop
ldns
+ lf
lsof
#mailutils # builds guile
multitail
nethogs
nload
nmon
+ pciutils # Not supported by a few hardwares
+ psmisc
pv
- rdfind
+ #rdfind
smem
- swaplist
tcpdump
tmux
tree
usbutils
- vim
+ #vim
which
#dnsutils
#ntop