-{ pkgs, config, ... }:
+{ pkgs, config, info, lib, ... }:
let
domain = "sourcephile.fr";
inherit (config.users) groups;
set output-net-lego-ipv4 {
type ipv4_addr
elements = {
- 217.70.177.42
+ ${lib.concatStringsSep ", " info.lebureau.dns.secondary.ns.ipv4}
}
}
set output-net-lego-ipv6 {
type ipv6_addr
elements = {
- 2001:4b98:d:1::4b
+ ${lib.concatStringsSep ", " info.lebureau.dns.secondary.ns.ipv6}
}
}
}
group = groups."acme".name;
keyType = "rsa4096";
dnsProvider = "rfc2136";
- dnsPropagationCheck = false;
+ #dnsPropagationCheck = false;
credentialsFile = pkgs.writeText "credentials" ''
RFC2136_NAMESERVER=127.0.0.1:5353
RFC2136_PROPAGATION_TIMEOUT=1000