};
stage1Dir = lib.mkOption {
type = types.str;
- default = "/run/secrets";
+ default = "/run/initrd-secrets";
description = ''
Where to store the secrets in the stage1
for `boot.initrd.secrets` to install them in the initrd.
'';
};
+ # Alas, nixos/modules/system/boot/initrd-ssh.nix
+ # forces stage2Dir == stage1Dir
stage2Dir = lib.mkOption {
type = types.str;
- default = "/root/initrd";
+ default = "/run/initrd-secrets";
description = ''
Where to store the secrets in the stage2
for `boot.initrd.secrets` to retrieve them when rebuilding the system.