mermet: knot: sourcephile.fr: remove Gandi as NS
[sourcephile-nix.git] / nixos / options.nix
index f454cc0d7719be80f9ba73133ab82e275f54047b..99e3e3a0877fa2efe8ad2432200f2e53fa5ee3ec 100644 (file)
@@ -19,15 +19,17 @@ with lib;
       };
       stage1Dir = lib.mkOption {
         type = types.str;
-        default = "/run/secrets";
+        default = "/run/initrd-secrets";
         description = ''
           Where to store the secrets in the stage1
           for `boot.initrd.secrets` to install them in the initrd.
         '';
       };
+      # Alas, nixos/modules/system/boot/initrd-ssh.nix
+      # forces stage2Dir == stage1Dir
       stage2Dir = lib.mkOption {
         type = types.str;
-        default = "/root/initrd";
+        default = "/run/initrd-secrets";
         description = ''
           Where to store the secrets in the stage2
           for `boot.initrd.secrets` to retrieve them when rebuilding the system.