Add given password for hosts/mermet/knot/autogeree.net/lebureau.conf to store.
[sourcephile-nix.git] / hosts / mermet / nebula.nix
index 0e0be8a683d92cf3ea3fbb2ea50f84c413fac40a..5298cf99a96dbf7a7e1fc8d57348b5ebeb8b20eb 100644 (file)
@@ -1,4 +1,10 @@
-{ pkgs, lib, config, inputs, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  inputs,
+  ...
+}:
 let
   domain = "sourcephile.fr";
   port = 10001;
@@ -6,7 +12,7 @@ let
 in
 {
   imports = [
-    (inputs.julm-nix + "/share/nebula/sourcephile.fr.nix")
+    (inputs.julm-nix + "/domains/sourcephile.fr/nebula.nix")
   ];
   services.nebula.networks.${domain} = {
     enable = true;
@@ -14,12 +20,23 @@ in
     isLighthouse = true;
     isRelay = true;
     firewall = {
-      outbound = [{ port = "any"; proto = "any"; host = "any"; }];
-      inbound = [{ port = "any"; proto = "any"; host = "any"; }];
+      outbound = [
+        {
+          port = "any";
+          proto = "any";
+          host = "any";
+        }
+      ];
+      inbound = [
+        {
+          port = "any";
+          proto = "any";
+          host = "any";
+        }
+      ];
     };
   };
-  networking.nftables.ruleset = ''
-  '';
+  networking.nftables.ruleset = '''';
   services.fail2ban.ignoreIP = [
     "${ipv4Prefix}.1/24"
   ];