-{ pkgs, lib, config, inputs, ... }:
+{
+ pkgs,
+ lib,
+ config,
+ inputs,
+ ...
+}:
let
domain = "sourcephile.fr";
port = 10001;
in
{
imports = [
- (inputs.julm-nix + "/share/nebula/sourcephile.fr.nix")
+ (inputs.julm-nix + "/domains/sourcephile.fr/nebula.nix")
];
services.nebula.networks.${domain} = {
enable = true;
isLighthouse = true;
isRelay = true;
firewall = {
- outbound = [{ port = "any"; proto = "any"; host = "any"; }];
- inbound = [{ port = "any"; proto = "any"; host = "any"; }];
+ outbound = [
+ {
+ port = "any";
+ proto = "any";
+ host = "any";
+ }
+ ];
+ inbound = [
+ {
+ port = "any";
+ proto = "any";
+ host = "any";
+ }
+ ];
};
};
- networking.nftables.ruleset = ''
- '';
+ networking.nftables.ruleset = '''';
services.fail2ban.ignoreIP = [
"${ipv4Prefix}.1/24"
];