sanoid: syncoid: crate new datasets for more fine grained backups
[sourcephile-nix.git] / base / zfs.nix
index 42a86f9443196681a4ba34dbe921995af7854332..fe8b7faa20f1208fb7ae16ee5b1249fec0cbbd91 100644 (file)
@@ -1,15 +1,11 @@
 { pkgs, lib, config, ... }:
 {
-# The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
-# You should try to make this id unique among your machines.
-# Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
-networking.hostId = "69c40b03";
-
 # none is the recommended elevator with ZFS (which has its own I/O scheduler)
 # and/or for SSD, whereas HDD could use mq-deadline.
 services.udev.extraRules = ''
   # set none scheduler for non-rotating disks
   ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="none"
+  ACTION=="add|change", KERNEL=="nvme[0-9]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="none"
 '';
 
 boot.supportedFilesystems = [ "zfs" ];