# to be able to start unattended, hence the key will be available
# to anyone who has physically access to the disk where /boot is.
# NOTE: dropbearkey -t ecdsa -f /tmp/dropbear-ecdsa.key
- #hostECDSAKey = "../../../sec/tmp/dropbear-ecdsa.key";
- hostECDSAKey = pass-to-file "servers/mermet/dropbear/ecdsa.key"
- (../../../sec + "/tmp/dropbear-ecdsa.key");
+ hostKeys = [
+ (pass-to-file "servers/mermet/ssh/ecdsa.key"
+ (../../../sec + "/tmp/mermet.ecdsa.key"))
+ ];
- # WARNING: dropbear does not support (and will ignore) ssh-ed25519 keys
authorizedKeys = users.users.root.openssh.authorizedKeys.keys;
};
# This will automatically load the zfs password prompt on login
"net.ipv6.conf.enp1s0.disable_ipv6" = 1;
};
-#services.nsd.interfaces = [ netIPv4 ];
services.knot.extraConfig = lib.mkBefore ''
server:
listen: ${netIPv4}@53