nginx: change paths and config on losurdo
[sourcephile-nix.git] / nixos / profiles / systems / zfs.nix
index af720d08d38820d16903dab3ba39b230d91c20d3..212ec2cf93578adb32046d675fea960612f81571 100644 (file)
@@ -14,8 +14,9 @@ boot.supportedFilesystems = [ "zfs" ];
 boot.zfs.forceImportAll  = false;
 boot.zfs.forceImportRoot = false;
 
-boot.zfs.enableUnstable = true;
-boot.zfs.requestEncryptionCredentials = true;
+boot.zfs.enableUnstable = false;
+# Can be overrided with a list of specific datasets
+boot.zfs.requestEncryptionCredentials = lib.mkDefault true;
 
 # Enables periodic scrubbing of ZFS pools.
 services.zfs.autoScrub.enable = true;