-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
{
hardware.cpu.amd.updateMicrocode = true;
nix = {
# Too CPU hungry for the APU2, for too little Mio saved
autoOptimiseStore = false;
- maxJobs = 4;
+ maxJobs = host.CPUs / 2;
};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
"uas"
# Ethernet driver
"igb"
- # Made the AES modules available at initrd,
+ # Make the AES modules available at initrd,
# to speedup the deciphering of the root.
- "aes_x86_64"
+ #"aes_x86_64"
"aesni_intel"
"cryptd"
];