dovecot: increase quota for julm
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index b8070a630067d46f34bfade85f0e27867f3c2567..a9e3073d4726c8b1f32c9eb4d837f80baff9ecf7 100644 (file)
@@ -1,10 +1,10 @@
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
 {
 hardware.cpu.amd.updateMicrocode = true;
 nix = {
   # Too CPU hungry for the APU2, for too little Mio saved
   autoOptimiseStore = false;
-  maxJobs = 4;
+  maxJobs = host.CPUs / 2;
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
@@ -50,9 +50,9 @@ boot.initrd = {
     "uas"
     # Ethernet driver
     "igb"
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];