dovecot: increase quota for julm
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index c380c77d4f485da6fe90eaade09675f702ed51cb..a9e3073d4726c8b1f32c9eb4d837f80baff9ecf7 100644 (file)
@@ -1,13 +1,18 @@
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
 {
 hardware.cpu.amd.updateMicrocode = true;
 nix = {
   # Too CPU hungry for the APU2, for too little Mio saved
   autoOptimiseStore = false;
-  maxJobs = 4;
+  maxJobs = host.CPUs / 2;
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+  SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
+
 boot.loader = {
   grub = {
     enable = true;
@@ -45,9 +50,9 @@ boot.initrd = {
     "uas"
     # Ethernet driver
     "igb"
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];
@@ -61,7 +66,7 @@ boot.kernelParams = [
   #"console=tty0"
   "console=ttyS0,115200n8"
   # Use arc_summary to print stats
-  "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+  #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
 ];
 
 environment.systemPackages = [