netns: update
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index c380c77d4f485da6fe90eaade09675f702ed51cb..d5733b559e53aac9337a9ba40a32fe9e4cbefba4 100644 (file)
@@ -8,6 +8,11 @@ nix = {
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+  SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
+
 boot.loader = {
   grub = {
     enable = true;
@@ -45,7 +50,7 @@ boot.initrd = {
     "uas"
     # Ethernet driver
     "igb"
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
     "aes_x86_64"
     "aesni_intel"
@@ -61,7 +66,7 @@ boot.kernelParams = [
   #"console=tty0"
   "console=ttyS0,115200n8"
   # Use arc_summary to print stats
-  "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+  #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
 ];
 
 environment.systemPackages = [