nix: update input secrets
[sourcephile-nix.git] / nixos / profiles / hardware / cubieboard2.nix
index 755b634a24b330147be79e90f99ead834aaf04b5..0560f99f4d00733f3cfd61bd160e6f778104fcaf 100644 (file)
@@ -5,7 +5,7 @@ imports = [
 ];
 
 # Too CPU hungry for this hardware, for too little Mio saved
-nix.autoOptimiseStore = false;
+nix.settings.auto-optimise-store = false;
 
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
@@ -74,6 +74,7 @@ nixpkgs.overlays = [
           USB_SERIAL_PL2303 = module;
           REGULATOR = lib.mkForce no;
           MFD_CORE = no;
+          PCI = yes;
 
           #
           # File systems
@@ -102,6 +103,16 @@ nixpkgs.overlays = [
           LIB80211_CRYPT_CCMP = module;
           MAC80211 = module;
           MAC80211_HWSIM = module;
+          NETDEVICES = yes;
+          WLAN = yes;
+          WLAN_VENDOR_REALTEK = yes;
+          NET_VENDOR_REALTEK = yes;
+          REALTEK_PHY = yes;
+          RTL_CARDS = module;
+          RTL8188EE = module; # For 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
+          RTLWIFI = module;
+          RTLWIFI_PCI = module;
+          RTLWIFI_DEBUG = yes;
 
           # Sound options
           SND_SOC_ADI = no;
@@ -693,6 +704,7 @@ nixpkgs.overlays = [
           MPI = no;
           RAID6 = no;
           STAGING = lib.mkForce no;
+          ATH11K_PCI = no;
 
           "6LOWPAN" = no;
           ARCNET = no;