Add given password for hosts/mermet/knot/autogeree.net/lebureau.conf to store.
[sourcephile-nix.git] / hosts / losurdo / system.nix
index 3c5f553cf362c6fcd569ae13dc3e77c8d0264a6a..091e65d3f3b5643972b7312b89aed64a88b96edc 100644 (file)
@@ -3,7 +3,12 @@
   # This value determines the NixOS release with which your system is to be
   # compatible, in order to avoid breaking some software such as database servers.
   # You should change this only after NixOS release notes say you should.
-  system.stateVersion = "19.09"; # Did you read the comment?
+  system.stateVersion = "24.11"; # Did you read the comment?
+
+  boot.initrd.systemd = {
+    enable = true;
+    emergencyAccess = true; # FIXME: use a password
+  };
 
   nix.gc.dates = "weekly";
   nix.gc.options = "--delete-older-than 7d";
   # when reinstalling NixOS on a new drive.
   # Manually generated with : uuidgen | tr -d -
   environment.etc.machine-id.source = ./machine-id.clear;
-  environment.systemPackages = with pkgs; [
-    bluez
-    cryptsetup
-    direnv
-    # f3 # broken
-    file
-    fio
-    gdb
-    git
-    gptfdisk
-    #hey
-    home-manager
-    lm_sensors
-    rsync
-    socat
-    sanoid
-    #iptables-nftables-compat
-    pkgs.gnupg
-    miniupnpc
-    audit
-    python
-  ];
 }