};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
-boot.kernel = {
- sysctl = {
- # Recommended to improve performance when RAM is sufficient.
- "vm.swappiness" = lib.mkDefault 10;
- };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+ SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
boot.loader = {
grub = {
"uas"
# Ethernet driver
"igb"
- # Made the AES modules available at initrd,
+ # Make the AES modules available at initrd,
# to speedup the deciphering of the root.
"aes_x86_64"
"aesni_intel"
#"console=tty0"
"console=ttyS0,115200n8"
# Use arc_summary to print stats
- "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+ #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
];
environment.systemPackages = [