nix: update switch from julm-nix
[sourcephile-nix.git] / hosts / losurdo / security.nix
index 1befae92a33da329693d373d609e16bfd8b524e7..b4788e7a9f754b3b0a81ee926b46351588e74772 100644 (file)
@@ -1,14 +1,8 @@
-{ inputs, pkgs, lib, config, ... }:
+{ ... }:
 {
-security.lockKernelModules = false;
-security.gnupg.agent = {
-  keyring."9AA84E6F6D71F9163C46BF396B141A0806219077" = {};
-};
-services.openssh.extraConfig = ''
-  # This is for removing remote gpg-agent's socket
-  StreamLocalBindUnlink yes
-'';
-environment.systemPackages = [
-  pkgs.tshark
-];
+  security.lockKernelModules = false;
+  services.openssh.extraConfig = ''
+    # This is for removing remote gpg-agent's socket
+    StreamLocalBindUnlink yes
+  '';
 }