mermet: knot: autogeree.net: move from Gandi to LeBureau
[sourcephile-nix.git] / hosts / carotte / nebula.nix
index 74dcae84ba0d22336618b4b930485ebb3c6565e2..a5a6902b48dab63315b9dfcfb7747a55d82aa6b7 100644 (file)
@@ -1,4 +1,10 @@
-{ pkgs, lib, config, inputs, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  inputs,
+  ...
+}:
 let
   domain = "sourcephile.fr";
   port = 10005;
@@ -6,7 +12,7 @@ let
 in
 {
   imports = [
-    (inputs.julm-nix + "/share/nebula/sourcephile.fr.nix")
+    (inputs.julm-nix + "/domains/sourcephile.fr/nebula.nix")
   ];
   services.nebula.networks.${domain} = {
     enable = true;
@@ -14,12 +20,23 @@ in
     isLighthouse = false;
     isRelay = false;
     firewall = {
-      outbound = [{ port = "any"; proto = "any"; host = "any"; }];
-      inbound = [{ port = "any"; proto = "any"; host = "any"; }];
+      outbound = [
+        {
+          port = "any";
+          proto = "any";
+          host = "any";
+        }
+      ];
+      inbound = [
+        {
+          port = "any";
+          proto = "any";
+          host = "any";
+        }
+      ];
     };
   };
-  networking.nftables.ruleset = ''
-  '';
+  networking.nftables.ruleset = '''';
   networking.networkmanager.unmanaged = [ config.services.nebula.networks.${domain}.tun.device ];
   #boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
 }