-{ config, host, ... }:
+{ config, inputs, host, ... }:
let
inherit (config.services) unbound;
inherit (config.users) users;
serviceConfig = {
RuntimeDirectory = "unbound";
RuntimeDirectoryMode = "0700";
+ BindReadOnlyPaths = [
+ "${inputs.self}/share/networking/named.root:/var/lib/unbound/named.root"
+ ];
};
- preStart = ''
- install -m 444 \
- ${../../networking/named.root} \
- /var/lib/unbound/named.root
- '';
};
}