mermet: dovecot: julm: increase mailQuota
[sourcephile-nix.git] / hosts / losurdo / unbound.nix
index 85b21594f62223387ca52430153fe4698398b920..1e8a9a7f8c8f6c02c97ba67c9c43a2973ae41774 100644 (file)
@@ -1,4 +1,4 @@
-{ config, host, ... }:
+{ config, inputs, host, ... }:
 let
   inherit (config.services) unbound;
   inherit (config.users) users;
@@ -153,11 +153,9 @@ in
     serviceConfig = {
       RuntimeDirectory = "unbound";
       RuntimeDirectoryMode = "0700";
+      BindReadOnlyPaths = [
+        "${inputs.self}/share/networking/named.root:/var/lib/unbound/named.root"
+      ];
     };
-    preStart = ''
-      install -m 444 \
-       ${../../networking/named.root} \
-       /var/lib/unbound/named.root
-    '';
   };
 }