nix: remove upstreamed PR patches
[sourcephile-nix.git] / servers / mermet / nginx / sourcephile.fr / git.nix
index 7ce0067bc4ea420d678ae9b945598ca291f6fce5..8a3294c6ddea19a76c0592da00cdad95420cbb67 100644 (file)
@@ -46,7 +46,7 @@ in
           '';
         };
         "/static-custom/" = {
-          root = pkgs.writeTextDir "style.css" ''
+          root = pkgs.writeTextDir "static-custom/style.css" ''
             .project_list {
               width:100%;
             }
@@ -112,6 +112,8 @@ in
       $projects_list_description_width = 50;
       $projects_list_group_categories = 1;
       $default_projects_order = "age";
+      $default_text_plain_charset = 'utf-8';
+      #$fallback_encoding = "utf-8";
       $omit_owner = 1;
       $export_ok = "git-daemon-export-ok";
       $prevent_xss = 0;
@@ -128,20 +130,6 @@ in
       $favicon     =  "/static/git-favicon.png";
       $javascript  =  "/static/gitweb.js";
       $feature{'highlight'}{'default'} = [1];
-      # Fix a bug in Gitweb: FCGI is not Unicode aware.
-      if ($first_request) {
-          my $enc = Encode::find_encoding('UTF-8');
-          my $org = \&FCGI::Stream::PRINT;
-          no warnings 'redefine';
-          *FCGI::Stream::PRINT = sub {
-              my @OUTPUT = @_;
-              for (my $i = 1; $i < @_; $i++) {
-                  $OUTPUT[$i] = $enc->encode($_[$i], Encode::FB_CROAK|Encode::LEAVE_SRC);
-              }
-              @_ = @OUTPUT;
-              goto $org;
-          };
-      };
     '';
   };
 }