mermet: fix MemoryHigh/MemoryMax confusion
[sourcephile-nix.git] / shell / modules / tools / package-management / nix.nix
index 041e0d2abbd27ce2351bc774401f36fab9ef8dcd..c2d6b7317d54f4c55e7336ef39c0b79da0ab3e36 100644 (file)
@@ -1,11 +1,12 @@
 { pkgs, lib, config, ... }:
-let cfg = config.nix;
-    inherit (lib) types;
-    # Alternative which does not need to re-export envvars when called via sudo.
-    # But this is maybe more clear to just (re-)export envvars.
-    # And anyway, using NIX_CONF_DIR=${cfg.nixConf} directly does not work,
-    # maybe because of filesystem restriction access set by nix, I don't know.
-    /*
+let
+  cfg = config.nix;
+  inherit (lib) types;
+  # Alternative which does not need to re-export envvars when called via sudo.
+  # But this is maybe more clear to just (re-)export envvars.
+  # And anyway, using NIX_CONF_DIR=${cfg.nixConf} directly does not work,
+  # maybe because of filesystem restriction access set by nix, I don't know.
+  /*
     nix = pkgs.writeShellScriptBin "nix" ''
       NIX_CONF_DIR=${cfg.nixConf} \
       NIX_SSL_CERT_FILE="${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt" \