friot/postgrey.nix
friot/rmilter.nix
friot/shorewall.nix
+ friot/openldap.nix
+ #friot/discourse.nix
];
options = {
enable = lib.mkEnableOption "friot";
+ networking.baseName = lib.mkOption {
+ type = types.str;
+ description = "Base network name.";
+ example = "example";
+ };
networking.zones = lib.mkOption {
- type = types.attrsOf (types.submodule ({zone, ...}: {
+ type = types.attrsOf (types.submodule ({name, options, config, ...}: {
options = {
iface = lib.mkOption {
type = types.str;
};
};
config = {
+ nixpkgs.overlays = import ../overlays.nix;
networking = {
- domain = "commonsoft.coop";
+ baseName = "commonsoft";
+ domain = "${config.networking.baseName}.coop";
};
users.mutableUsers = false;
users.users = {
openssh = {
enable = true;
};
- openldap = {
- enable = true;
- #declarativeContents = ''
- # dn: dc=example,dc=org
- # objectClass: domain
- # dc: example
- #
- # dn: ou=users,dc=example,dc=org
- # objectClass = organizationalUnit
- # ou: users
- #
- # # ...
- #'';
- };
gitea = {
enable = false;
};
+ sssd = {
+ enable = false;
+ };
dovecot2 = {
#debug = true;
};
inetutils
cgit
ncdu
- #mailutils
+ mailutils
+ #sssd
+ docker
+ #nss_ldap
+ #nss_pam_ldapd
+ socat
];
};
};