Makefile: add %/verbose.
[sourcephile-nix.git] / install / logical / friot.nix
index fcb335b2ee37b1edef5dade5dfaab501fb5dcd26..df839fc3df7517f25292a517f436c8c12a4a8b9a 100644 (file)
@@ -14,11 +14,18 @@ imports = [
   friot/postgrey.nix
   friot/rmilter.nix
   friot/shorewall.nix
+  friot/openldap.nix
+  #friot/discourse.nix
 ];
 options = {
   enable = lib.mkEnableOption "friot";
+  networking.baseName = lib.mkOption {
+    type        = types.str;
+    description = "Base network name.";
+    example     = "example";
+  };
   networking.zones = lib.mkOption {
-    type = types.attrsOf (types.submodule ({zone, ...}: {
+    type = types.attrsOf (types.submodule ({name, options, config, ...}: {
       options = {
         iface = lib.mkOption {
           type        = types.str;
@@ -40,8 +47,10 @@ options = {
   };
 };
 config = {
+  nixpkgs.overlays = import ../overlays.nix;
   networking = {
-    domain = "commonsoft.coop";
+    baseName = "commonsoft";
+    domain   = "${config.networking.baseName}.coop";
   };
   users.mutableUsers = false;
   users.users = {
@@ -74,23 +83,12 @@ config = {
     openssh = {
       enable = true;
     };
-    openldap = {
-      enable = true;
-      #declarativeContents = ''
-      #    dn: dc=example,dc=org
-      #    objectClass: domain
-      #    dc: example
-      #
-      #    dn: ou=users,dc=example,dc=org
-      #    objectClass = organizationalUnit
-      #    ou: users
-      #
-      #    # ...
-      #'';
-    };
     gitea = {
       enable = false;
     };
+    sssd = {
+      enable = false;
+    };
     dovecot2 = {
       #debug = true;
     };
@@ -160,7 +158,12 @@ config = {
       inetutils
       cgit
       ncdu
-      #mailutils
+      mailutils
+      #sssd
+      docker
+      #nss_ldap
+      #nss_pam_ldapd
+      socat
     ];
   };
 };