public-inbox: fix to support the current nixpkgs
[sourcephile-nix.git] / hosts / carotte / security.nix
index 6d648337644ff8c3a84298de3f1406eff10c5678..e582910085e263d6b9817e3facbd8e4e746e44aa 100644 (file)
@@ -1,15 +1,17 @@
-{ inputs, pkgs, lib, config, ... }:
+{ lib, ... }:
 {
-security.lockKernelModules = false;
-security.virtualisation.flushL1DataCache = lib.mkForce null;
-security.gnupg.agent = {
-  keyring."C7BCEA3D090956E7D51E94ADFF53191D9FA89552" = {
-    passwordGpg = "gnupg/root.gpg";
-    passwordFile = "/root/.gnupg.C7BCEA3D090956E7D51E94ADFF53191D9FA89552.txt";
+  security.lockKernelModules = false;
+  security.virtualisation.flushL1DataCache = lib.mkForce null;
+  /*
+  security.gnupg.agent = {
+    keyring."C7BCEA3D090956E7D51E94ADFF53191D9FA89552" = {
+      passwordGpg = "gnupg/root.gpg";
+      passwordFile = "/root/.gnupg.C7BCEA3D090956E7D51E94ADFF53191D9FA89552.txt";
+    };
   };
-};
-services.openssh.extraConfig = ''
-  # This is for removing remote gpg-agent's socket
-  StreamLocalBindUnlink yes
-'';
+  services.openssh.extraConfig = ''
+    # This is for removing remote gpg-agent's socket
+    StreamLocalBindUnlink yes
+  '';
+  */
 }