sanoid: keep monthly snapshots (and hopefully bookmarks)
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 08014574e33072ffa12e769b9dd40139dd3b7124..9e9af14ea73797df6b16709a207a32391677403a 100644 (file)
@@ -1,11 +1,18 @@
 { pkgs, lib, config, ... }:
 {
 hardware.cpu.intel.updateMicrocode = true;
-nix = {
-  # Too CPU hungry for the DL10J, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = 2;
+hardware.opengl = {
+  extraPackages = [
+    pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
+    pkgs.vaapiIntel         # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
+    pkgs.vaapiVdpau
+    pkgs.libvdpau-va-gl
+  ];
 };
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.autoOptimiseStore = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
 # https://insanity.industries/post/sata-power-consumption/
@@ -14,11 +21,15 @@ services.udev.extraRules = ''
 '';
 
 boot.loader = {
+  efi = {
+    canTouchEfiVariables = false;
+    efiSysMountPoint = "/boot/efi";
+  };
   grub = {
     enable = true;
     version = 2;
     copyKernels = true;
-    configurationLimit = 3;
+    configurationLimit = 9;
     efiSupport = true;
     # Because canTouchEfiVariables doesn't work on this system
     efiInstallAsRemovable = true;
@@ -33,10 +44,6 @@ boot.loader = {
     ];
     */
   };
-  efi = {
-    canTouchEfiVariables = false;
-    efiSysMountPoint = "/boot/efi";
-  };
 };
 
 boot.initrd = {
@@ -53,9 +60,9 @@ boot.initrd = {
     "xhci_hcd" # USB
     #"i915" # VGA
     "igb" # Ethernet
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];
@@ -63,9 +70,13 @@ boot.initrd = {
     "igb" # Ethernet
     "nvme" # NVME M.2 disk
     "rtsx_usb_sdmmc" # SD card
+    "ums_realtek" # SD card
   ];
 };
-boot.kernelModules = [ ];
+boot.kernelModules = [
+  "rtsx_usb_sdmmc" # SD card
+  "ums_realtek" # SD card
+];
 boot.extraModulePackages = [ ];
 boot.kernelParams = [
   "gfxpayload=text"
@@ -74,6 +85,9 @@ boot.kernelParams = [
   "console=tty0"
 ];
 
+# rtlwifi/rtl8188efw.bin
+hardware.enableRedistributableFirmware = true;
+
 environment.systemPackages = with pkgs; [
   pciutils
   nvme-cli