nix: update to latest julm-nix
[sourcephile-nix.git] / hosts / mermet / croc.nix
index 619c48d0577dba20dcba1f3cc93935436ef2d121..946ef6e483e3ef44880918166ea638d47f0e51b4 100644 (file)
@@ -4,11 +4,15 @@ let
 in
 {
 networking.nftables.ruleset = ''
-  add rule inet filter net2fw tcp dport {${lib.concatMapStringsSep "," toString croc.ports}} counter accept comment "croc"
+  table inet filter {
+    chain input-net {
+      tcp dport {${lib.concatMapStringsSep "," toString croc.ports}} counter accept comment "croc"
+    }
+  }
 '';
 services.croc = {
   enable = true;
-  pass = builtins.readFile (inputs.secrets + "/croc/pass");
+  pass = builtins.readFile croc/pass.clear;
   #debug = true;
 };
 }