]> Git — Sourcephile - tmp/julm/symantic-reify.git/blob - default.nix
add nix files
[tmp/julm/symantic-reify.git] / default.nix
1 { pkgs ? import <nixpkgs> {}
2 , ghc ? "ghc901"
3 , withHoogle ? false
4 }:
5 let
6 haskellPackages =
7 if ghc == null
8 then pkgs.haskellPackages
9 else pkgs.haskell.packages.${ghc};
10 hs = haskellPackages.extend (with pkgs.haskell.lib; hself: hsuper:
11 {
12 symantic-reify = buildFromSdist (hself.callCabal2nix "symantic-reify" ./. {});
13 }
14 );
15 in hs.symantic-reify // {
16 shell = hs.shellFor {
17 doBenchmark = true;
18 packages = p: [ p.symantic-reify ];
19 nativeBuildInputs = [
20 hs.cabal-install
21 hs.ghcid
22 ];
23 buildInputs = [
24 ];
25 inherit withHoogle;
26 };
27 }