]> Git — Sourcephile - gargantext.git/blob - build-shell.nix
Merge branch 'update-build-shell-nix-merge' of ssh://gitlab.iscpif.fr:20022/gargantex...
[gargantext.git] / build-shell.nix
1 { ghc
2 , pkgs ? import ./pinned.nix {}
3 }:
4 let
5 buildInputs = with pkgs; [
6 bzip2
7 gmp
8 gsl
9 igraph
10 liblapack
11 lzma
12 pcre
13 postgresql
14 xz
15 zlib
16 blas
17 gfortran7
18 gfortran7.cc.lib
19 ];
20
21 libraryPaths = pkgs.lib.makeLibraryPath buildInputs;
22 in
23 pkgs.haskell.lib.buildStackProject rec {
24 inherit ghc;
25 inherit buildInputs;
26 name = "gargantext";
27
28 shellHook = ''
29 export LD_LIBRARY_PATH="${libraryPaths}"
30 export LIBRARY_PATH="${libraryPaths}"
31 '';
32 }