]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
[WIP]
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-22.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8107;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 pkgs.haskellPackages.llvm-hs
10 ];
11 nonhsBuildInputs = with pkgs; [
12 bzip2
13 czmq
14 docker-compose
15 git
16 gmp
17 gsl
18 #haskell-language-server
19 hlint
20 igraph
21 liblapack
22 lzma
23 pcre
24 pkgconfig
25 postgresql
26 xz
27 zlib
28 blas
29 gfortran7
30 # gfortran7.cc.lib
31 expat
32 icu
33 graphviz
34 libffi
35 llvmPackages_9.llvm
36 ];
37 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
38 shellHook = ''
39 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
40 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
41 '';
42 shell = pkgs.mkShell {
43 name = "gargantext-shell";
44 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
45 inherit shellHook;
46 };
47 }