]> Git — Sourcephile - gargantext.git/blob - nix/overlays/cabal-install-3.10.1.0.nix
Merge remote-tracking branch 'origin/dev-phylo' into dev
[gargantext.git] / nix / overlays / cabal-install-3.10.1.0.nix
1 { mkDerivation, array, async, base, base16-bytestring, binary
2 , bytestring, Cabal, Cabal-described ? null, cabal-install-solver
3 , Cabal-QuickCheck ? null, Cabal-syntax, Cabal-tree-diff ? null, containers
4 , cryptohash-sha256, directory, echo, edit-distance, exceptions
5 , filepath, hackage-security, hashable, HTTP, lib, lukko, mtl
6 , network-uri, parsec, pretty, pretty-show, process, QuickCheck
7 , random, regex-base, regex-posix, resolv, safe-exceptions, stm
8 , tagged, tar, tasty, tasty-expected-failure, tasty-golden
9 , tasty-hunit, tasty-quickcheck, text, time, tree-diff, unix, zlib
10 }:
11 mkDerivation {
12 pname = "cabal-install";
13 version = "3.10.1.0";
14 sha256 = "995de368555449230e0762b259377ed720798717f4dd26a4fa711e8e41c7838d";
15 revision = "1";
16 editedCabalFile = "0h1ra9kw7mk70202whiphbdyvknm7jbhqhkgw4h8abb1sgffhs3n";
17 isLibrary = true;
18 isExecutable = true;
19 libraryHaskellDepends = [
20 array async base base16-bytestring binary bytestring Cabal
21 cabal-install-solver Cabal-syntax containers cryptohash-sha256
22 directory echo edit-distance exceptions filepath hackage-security
23 hashable HTTP lukko mtl network-uri parsec pretty process random
24 regex-base regex-posix resolv safe-exceptions stm tar text time
25 unix zlib
26 ];
27 executableHaskellDepends = [
28 base Cabal Cabal-syntax directory filepath
29 ];
30 testHaskellDepends = [
31 array base bytestring Cabal Cabal-described cabal-install-solver
32 Cabal-QuickCheck Cabal-syntax Cabal-tree-diff containers directory
33 filepath hashable mtl network-uri pretty-show QuickCheck random
34 tagged tar tasty tasty-expected-failure tasty-golden tasty-hunit
35 tasty-quickcheck time tree-diff zlib
36 ];
37 doCheck = false;
38 doHaddock = false;
39 enableExecutableProfiling = false;
40 postInstall = ''
41 mkdir -p $out/share/bash-completion
42 mv bash-completion $out/share/bash-completion/completions
43 '';
44 homepage = "http://www.haskell.org/cabal/";
45 description = "The command-line interface for Cabal and Hackage";
46 license = lib.licenses.bsd3;
47 mainProgram = "cabal";
48 }