]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
Merge branch 'dev' into dev-corpora-from-write-nodes
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-21.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8104;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 ];
10 nonhsBuildInputs = with pkgs; [
11 bzip2
12 git
13 gmp
14 gsl
15 #haskell-language-server
16 hlint
17 igraph
18 liblapack
19 lzma
20 pcre
21 pkgconfig
22 postgresql
23 xz
24 zlib
25 blas
26 gfortran7
27 # gfortran7.cc.lib
28 ];
29 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
30 shellHook = ''
31 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
32 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
33 '';
34 shell = pkgs.mkShell {
35 name = "gargantext-shell";
36 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
37 inherit shellHook;
38 };
39 }