]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
Merge remote-tracking branch 'origin/dev-phylo' into dev-merge
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-22.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8107;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 ];
10 nonhsBuildInputs = with pkgs; [
11 bzip2
12 czmq
13 docker-compose
14 git
15 gmp
16 gsl
17 #haskell-language-server
18 hlint
19 igraph
20 libffi
21 liblapack
22 lzma
23 pcre
24 pkgconfig
25 postgresql
26 xz
27 zlib
28 blas
29 gfortran7
30 # gfortran7.cc.lib
31 expat
32 icu
33 graphviz
34 llvm_9
35 ];
36 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
37 shellHook = ''
38 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
39 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
40 '';
41 shell = pkgs.mkShell {
42 name = "gargantext-shell";
43 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
44 inherit shellHook;
45 };
46 }