]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
Merge remote-tracking branch 'origin/396-dev-team-management' into dev-merge
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-22.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8107;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 pkgs.haskellPackages.llvm-hs
10 ];
11 nonhsBuildInputs = with pkgs; [
12 bzip2
13 czmq
14 docker-compose
15 git
16 gmp
17 gsl
18 #haskell-language-server
19 hlint
20 igraph
21 libffi
22 liblapack
23 lzma
24 pcre
25 pkgconfig
26 postgresql
27 xz
28 zlib
29 blas
30 gfortran7
31 # gfortran7.cc.lib
32 expat
33 icu
34 graphviz
35 llvm_9
36 ];
37 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
38 shellHook = ''
39 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
40 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
41 '';
42 shell = pkgs.mkShell {
43 name = "gargantext-shell";
44 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
45 inherit shellHook;
46 };
47 }