]> Git — Sourcephile - gargantext.git/blob - build-shell.nix
[phylo] filter threshold changed
[gargantext.git] / build-shell.nix
1 { ghc
2 , pkgs ? import ./pinned.nix {}
3 }:
4 let
5 buildInputs = with pkgs; [
6 bzip2
7 git
8 gmp
9 gsl
10 igraph
11 liblapack
12 lzma
13 pcre
14 postgresql
15 xz
16 zlib
17 blas
18 gfortran7
19 gfortran7.cc.lib
20 ];
21
22 libraryPaths = pkgs.lib.makeLibraryPath buildInputs;
23 in
24 pkgs.haskell.lib.buildStackProject rec {
25 inherit ghc;
26 inherit buildInputs;
27 name = "gargantext";
28
29 shellHook = ''
30 export LD_LIBRARY_PATH="${libraryPaths}"
31 export LIBRARY_PATH="${libraryPaths}"
32 '';
33 }