]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
Merge branch 'dev' into 97-dev-istex-search
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-21.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8104;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 ];
10 nonhsBuildInputs = with pkgs; [
11 bzip2
12 czmq
13 docker-compose
14 git
15 gmp
16 gsl
17 #haskell-language-server
18 hlint
19 igraph
20 liblapack
21 lzma
22 pcre
23 pkgconfig
24 postgresql
25 xz
26 zlib
27 blas
28 gfortran7
29 # gfortran7.cc.lib
30 expat
31 icu
32 graphviz
33 ];
34 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
35 shellHook = ''
36 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
37 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
38 '';
39 shell = pkgs.mkShell {
40 name = "gargantext-shell";
41 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
42 inherit shellHook;
43 };
44 }