]> Git — Sourcephile - gargantext.git/blob - nix/overlays/Cabal-3.10.1.0.nix
Merge branch 'adinapoli/improve-cabal' into dev
[gargantext.git] / nix / overlays / Cabal-3.10.1.0.nix
1 { mkDerivation, array, base, bytestring, Cabal-syntax, containers
2 , deepseq, directory, filepath, lib, mtl, parsec, pretty, process
3 , text, time, transformers, unix
4 }:
5 mkDerivation {
6 pname = "Cabal";
7 version = "3.10.1.0";
8 sha256 = "0bdbab8e4c3178016fb0f070d8b62bc3067f93afabfbd3aa17c8065d0ecc98ee";
9 setupHaskellDepends = [ mtl parsec ];
10 libraryHaskellDepends = [
11 array base bytestring Cabal-syntax containers deepseq directory
12 filepath mtl parsec pretty process text time transformers unix
13 ];
14 doCheck = false;
15 doHaddock = false;
16 homepage = "http://www.haskell.org/cabal/";
17 description = "A framework for packaging Haskell software";
18 license = lib.licenses.bsd3;
19 }