]> Git — Sourcephile - gargantext.git/blob - nix/overlays/cabal-install-solver-3.10.1.0.nix
Merge branch 'adinapoli/improve-cabal' into dev
[gargantext.git] / nix / overlays / cabal-install-solver-3.10.1.0.nix
1 { mkDerivation, array, base, bytestring, Cabal, Cabal-syntax
2 , containers, edit-distance, filepath, lib, mtl, pretty, tasty
3 , tasty-hunit, tasty-quickcheck, transformers
4 }:
5 mkDerivation {
6 pname = "cabal-install-solver";
7 version = "3.10.1.0";
8 sha256 = "2c0d9edd4ccd746e9bf8ab4f92b1ecffe2f56eae29395c67ef5ca091a6f49f37";
9 revision = "1";
10 editedCabalFile = "1l3qhaiv0m2xc5vscggd2drinam1k4x0l3vfvvz15xrpvxypdv4d";
11 libraryHaskellDepends = [
12 array base bytestring Cabal Cabal-syntax containers edit-distance
13 filepath mtl pretty transformers
14 ];
15 testHaskellDepends = [
16 base Cabal Cabal-syntax tasty tasty-hunit tasty-quickcheck
17 ];
18 homepage = "http://www.haskell.org/cabal/";
19 description = "The command-line interface for Cabal and Hackage";
20 license = lib.licenses.bsd3;
21 doCheck = false;
22 doHaddock = false;
23 }