]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
Merge branch 'dev' into dev-sources-chart-sort
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-21.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8104;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 ];
10 nonhsBuildInputs = with pkgs; [
11 bzip2
12 docker-compose
13 git
14 gmp
15 gsl
16 #haskell-language-server
17 hlint
18 igraph
19 liblapack
20 lzma
21 pcre
22 pkgconfig
23 postgresql
24 xz
25 zlib
26 blas
27 gfortran7
28 # gfortran7.cc.lib
29 expat
30 icu
31 ];
32 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
33 shellHook = ''
34 export LD_LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}:$LD_LIBRARY_PATH"
35 export LIBRARY_PATH="${pkgs.gfortran7.cc.lib}:${libPaths}"
36 '';
37 shell = pkgs.mkShell {
38 name = "gargantext-shell";
39 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
40 inherit shellHook;
41 };
42 }