]> Git — Sourcephile - gargantext.git/blob - nix/pkgs.nix
make gargantext buildable with stack & cabal in a nix environment
[gargantext.git] / nix / pkgs.nix
1 { pkgs ? import ./pinned-21.05.nix {} }:
2
3 rec {
4 inherit pkgs;
5 ghc = pkgs.haskell.compiler.ghc8104;
6 hsBuildInputs = [
7 ghc
8 pkgs.cabal-install
9 ];
10 nonhsBuildInputs = with pkgs; [
11 bzip2
12 git
13 gmp
14 gsl
15 igraph
16 liblapack
17 lzma
18 pcre
19 pkgconfig
20 postgresql
21 xz
22 zlib
23 blas
24 gfortran7
25 gfortran7.cc.lib
26 ];
27 libPaths = pkgs.lib.makeLibraryPath nonhsBuildInputs;
28 shellHook = ''
29 export LD_LIBRARY_PATH="${libPaths}"
30 export LIBRARY_PATH="${libPaths}"
31 '';
32 shell = pkgs.mkShell {
33 name = "gargantext-shell";
34 buildInputs = hsBuildInputs ++ nonhsBuildInputs;
35 inherit shellHook;
36 };
37 }