]> Git — Sourcephile - haskell/literate-accounting.git/blob - default.nix
next
[haskell/literate-accounting.git] / default.nix
1 { pkgs ? import <nixpkgs> {}
2 , ghc ? null # "ghc901"
3 , withHoogle ? false
4 , inputs
5 , ...
6 }:
7 let
8 haskellPackages =
9 if ghc == null
10 then pkgs.haskellPackages
11 else pkgs.haskell.packages.${ghc};
12 hs = haskellPackages.extend (with pkgs.haskell.lib; hself: hsuper:
13 {
14 symantic-compta = buildFromSdist (hself.callCabal2nix "symantic-compta" ./. {});
15 symantic-base = buildFromSdist (hself.callCabal2nix "symantic-base" inputs.symantic-base {});
16 symantic-formatter = buildFromSdist (hself.callCabal2nix "symantic-formatter" inputs.symantic-formatter {});
17 }
18 );
19 in hs.symantic-compta // {
20 shell = hs.shellFor {
21 #doBenchmark = true;
22 packages = p: [ p.symantic-compta ];
23 nativeBuildInputs = [
24 hs.cabal-install
25 hs.ghcid
26 #hs.haskell-language-server
27 hs.doctest
28 ];
29 buildInputs = [
30 ];
31 inherit withHoogle;
32 };
33 }