]> Git — Sourcephile - haskell/symantic-parser.git/blob - default.nix
Rename many things and continue Instr interpretation
[haskell/symantic-parser.git] / default.nix
1 { pkgs ? import <nixpkgs> {}
2 , ghc ? null # "ghc8102"
3 , withHoogle ? false
4 #, symantic-base ? null
5 }:
6 let
7 haskellPackages =
8 if ghc == null
9 then pkgs.haskellPackages
10 else pkgs.haskell.packages.${ghc};
11 hs = haskellPackages.extend (with pkgs.haskell.lib;
12 hself: hsuper: {
13 symantic-base = hself.callCabal2nix "symantic-base" (pkgs.fetchgit {
14 url = "git://git.sourcephile.fr/haskell/symantic-base";
15 sha256 = "sha256-I636Kl+S93BDX1xrEMQdf217pLeT6FeF4BBpj83sEgQ=";
16 }) {};
17 } //
18 packageSourceOverrides {
19 symantic-parser = ./.;
20 } hself hsuper
21 );
22 in hs.symantic-parser // {
23 shell = hs.shellFor {
24 packages = p: [ p.symantic-parser ];
25 nativeBuildInputs = [
26 hs.cabal-install
27 hs.haskell-language-server
28 ];
29 buildInputs = [
30 #hs.ghcid
31 #hs.ormolu
32 hs.hlint
33 #pkgs.nixpkgs-fmt
34 ];
35 inherit withHoogle;
36 };
37 }