1 { pkgs ? import <nixpkgs> {}
9 then pkgs.haskellPackages
10 else pkgs.haskell.packages.${ghc};
11 hs = haskellPackages.extend (with pkgs.haskell.lib; hself: hsuper:
13 #symantic-parser = enableExecutableProfiling (doCheck ( hself.callCabal2nix "symantic-parser" ./. {}));
14 # FIXME: this should not be necessary, but haskellPackages.ormolu is currently broken.
16 text-short = dontCheck hsuper.text-short;
17 hs-speedscope = doJailbreak (unmarkBroken hsuper.hs-speedscope);
18 eventlog2html = doJailbreak (unmarkBroken hsuper.eventlog2html);
19 trie-simple = doJailbreak (unmarkBroken hsuper.trie-simple);
20 symantic-base = buildFromSdist (hself.callCabal2nix "symantic-base" inputs.symantic-base {});
21 symantic-parser = doBenchmark (buildFromSdist (hself.callCabal2nix "symantic-parser" ./. {}));
23 hlint = hsuper.hlint_3_3_1.overrideScope (self: super: {
24 ghc-lib-parser = overrideCabal self.ghc-lib-parser_9_0_1_20210324 {
27 ghc-lib-parser-ex = self.ghc-lib-parser-ex_9_0_0_4;
32 in hs.symantic-parser // {
35 packages = p: [ p.symantic-parser ];
36 # FIXME: remove when Nixpkgs' haskellPackages.ormolu is no longer broken
37 CABAL_TEST_FLAGS = "-fdisable-ormolu-check";
48 #hs.ghc-events-analyze
49 #hs.haskell-language-server